Internal System Issue
Incident Report for B Tag Inc
Resolved
This incident has been resolved.
Posted Jul 04, 2020 - 23:31 CDT
Investigating
We are currently investigating a issue where customer service is unable to access the Website Platform. At this time it is unknown if customers are having issues. If you are having issues accessing your B Tag Inc My Account please reach out to support@btaginc.com
Posted Jul 04, 2020 - 19:05 CDT
This incident affected: Websites (B Tag Inc Website Builder).