Primary Telephone Number Outage
Incident Report for B Tag Inc
Resolved
This incident has been resolved, if you are experiencing issues please reach out to us via email at Support@btaginc.com or via Facebook Messenger or Twitter DM's. Thank you!
Posted Jul 13, 2020 - 12:41 CDT
Monitoring
Our team is working to resolve this outage, thank you for your patience. We do believe the error has corrected itself yet we are monitoring it. The best support option available is still Support@btaginc.com or via Facebook Messenger or Twitter DM's.
Posted Jul 13, 2020 - 12:39 CDT
Identified
We have identified the issue preventing incoming and outgoing calls. At this time Incoming calls are working as expected. Outgoing calls from B Tag Inc are currently appearing as "No Caller ID" or 651-480-7818
Posted Jul 13, 2020 - 12:14 CDT
Investigating
We are currently investigating an issue where our primary telephone number +1 651-480-0044 is disconnected/ not in service. At this time if you need assistance please call +1 651-480-7818 or email support at Support@btaginc.com
Posted Jul 13, 2020 - 12:07 CDT
This incident affected: Communication (B Tag Inc Phone System).